JSON Web Token (JWT, sometimes pronounced /dʒɒt/[1]) is a JSON-based open standard (RFC 7519) for creating access tokens that assert some number of claims. For example, a server could generate a token that has the claim "logged in as admin" and provide that to a client. The client could then use that token to prove that it is logged in as admin. The tokens are signed by one party's private key (usually the server's), so that both parties (the other already being, by some suitable and trustworthy means, in possession of the corresponding public key) are able to verify that the token is legitimate. The tokens are designed to be compact,[2] URL-safe,[3] and usable especially in web browser single sign-on (SSO) context. JWT claims can be typically used to pass identity of authenticated users between an identity provider and a service provider, or any other type of claims as required by business processes.[4][5]
JWT relies on other JSON-based standards: JWS (JSON Web Signature) RFC 7515 and JWE (JSON Web Encryption) RFC 7516.[6][7][8]
JSON Web Tokens are an open, industry standard RFC 7519 method for representing claims securely between two parties.
This blog offers some guidelines for running a production grade Kubernetes cluster in an environment like an on-premise data center or edge location.
What does it mean to be “production grade”?
The installation is secure
The deployment is managed with a repeatable and recorded process
Performance is predictable and consistent
Updates and configuration changes can be safely applied
Logging and monitoring is in place to detect and diagnose failures and resource shortages
Service is “highly available enough” considering available resources, including constraints on money, physical space, power, etc.
A recovery process is available, documented, and tested for use in the event of failures
In short, production grade means anticipating accidents and preparing for recovery with minimal pain and delay.
This article is directed at on-premise Kubernetes deployments on a hypervisor or bare-metal platform, facing finite backing resources compared to the expansibility of the major public clouds. However, some of these recommendations may also be useful in a public cloud if budget constraints limit the resources you choose to consume.
A single node bare-metal Minikube deployment may be cheap and easy, but is not production grade. Conversely, you’re not likely to achieve Google’s Borg experience in a retail store, branch office, or edge location, nor are you likely to need it.
This blog offers some guidance on achieving a production worthy Kubernetes deployment, even when dealing with some resource constraints.
Wenn die Kiste widerspenstig ums Eck biegt oder mehr taumelt, als sauber geradeaus zu laufen, kann das verschiedene Gründe haben. Vor umfangreichen Setup-Änderungen steht ein gründlicher Rundum-Check.
Deutschland hat Angst vorm Klimawandel – und vor Ventilatoren. Während im Winter die nächste Klimakatastrophe droht, tut die Regierung nichts. Weil sie die vielen "Dummen" nicht verprellen will.
The multi-repository documentation site generator for tech writers who love writing in AsciiDoc.
AsciiDoc is a lightweight markup language for authoring notes, articles, documentation, books, web pages, slide decks and man pages in plain text. This guide is a quick reference for the common AsciiDoc document and text formatting markup
“fgallery” is a static photo gallery generator with no frills that has a stylish, minimalist look. “fgallery” shows your photos, and nothing else.
There is no server-side processing, only static generation. The resulting gallery can be uploaded anywhere without additional requirements and works with any modern browser.
NATO: Die Gründungs-Lüge
Veröffentlicht in: Außen- und Sicherheitspolitik, Audio-Podcast, Aufrüstung, Militäreinsätze/Kriege, Strategien der Meinungsmache
Werner Rügemer
Das ist ein Beitrag von Werner Rügemer. Er bietet eine für viele Menschen neue Sicht der Zusammenhänge und der Motive, die zur Gründung der NATO führten. Rügemers Sicht liegt quer zur gängigen Erzählung über die Gründung der NATO. Wer die damalige Zeit, wer die Debatten um die Wiederbewaffnung Deutschlands erlebt hat, kann der Sicht Rügemers einiges abgewinnen. Wahrscheinlich würde der frühere Bundespräsident Gustav Heinemann, der wegen der Wiederbewaffnung die CDU verlassen hat und 1950 aus dem Kabinett Adenauer ausgetreten ist, vieles ähnlich sehen. Albrecht Müller.
gVisor is a user-space kernel, written in Go, that implements a substantial portion of the Linux system surface. It includes an Open Container Initiative (OCI) runtime called runsc that provides an isolation boundary between the application and the host kernel. The runsc runtime integrates with Docker and Kubernetes, making it simple to run sandboxed containers.
gVisor takes a distinct approach to container sandboxing and makes a different set of technical trade-offs compared to existing sandbox technologies, thus providing new tools and ideas for the container security landscape.