This is a Gnome Shell extension implementing modern windows tiling system by extending GNOME's default 2 columns to any layout you want! Can be installed on Gnome Shells from 42 to 48 on X11 and Wayland: the most recent GNOME Shell is supported, and older releases will include all the features and bug fixes!
- 🤩 First and only extension that provides Windows 11's snap assistant
- 🖥️🖥️ multiple monitors support, even with different scaling factors!
- ⚙️ Manage, edit, create and delete layouts with a built-in editor
- 💡 Layouts are not strict, you can span multiple tiles if you want
- 🚀 Automatically sets the same UI of your GNOME theme, for a seamless integration!
You can use Docker with the Dev Containers extension in a few ways:
- Docker installed locally.
- Docker installed on another machine or remote environment.
- You only need Docker installed on the remote host, rather than Docker installed locally.
- Other Docker compliant CLIs, installed locally or in a remote environment.
- For instance, Rancher Desktop is another way to install Docker, providing container management and Kubernetes on Windows, macOS, and Linux.
- Since Rancher Desktop supports Docker CLI via Moby, you can use Dev Containers extension with it. You may learn how to get started in Rancher Desktop's guide.
- Dev Containers interacts with CLIs; it makes no assumptions about how a container engine works and does not interact with container engines or daemons directly.
- Note that other Docker compliant CLIs are not officially supported.
Continue reading to learn alternate ways you can install and use Docker or a Docker compliant CLI.
- VSCode extension: Dev Containers
- GitHub - microsoft/vscode-remote-release: Visual Studio Code Remote Development: Open any folder in WSL, in a Docker container, or on a remote machine using SSH and take advantage of VS Code's full feature set.
- Visual Studio Code Remote Development
- Developing inside a Container using Visual Studio Code Remote Development
Lunr provides a great search experience for readers without having to rely on external search services. With this extension, you can add offline, full-text search powered by Lunr to your Antora documentation site.
To add search functionality powered by Lunr to your Antora documentation site, you need to install this extension package, register the extension in your Antora playbook file, and add the search interface to the pages in your site. Let’s get started.
![]()

VSCodeVim is a Vim emulator for Visual Studio Code.
-
🚚 For a full list of supported Vim features, please refer to our roadmap.
-
📃 Our change log outlines the breaking/major/minor updates between
releases. -
Report missing features/bugs on GitHub.
This extension allows you to embed Graphviz graphs in your documents.
Markdown is a lightweight markup language with a simplistic plain text formatting syntax. It exists in many syntactically different flavors. To support Markdown-based documentation, Sphinx can use MyST-Parser. MyST-Parser is a Docutils bridge to markdown-it-py, a Python package for parsing the CommonMark Markdown flavor.
Atlassian® Confluence® Builder for Sphinx is a community provided extension to help build Confluence supported format files (e.g. storage format) and publish them to a Confluence instance.
License: BSD-2-Clause
Confluence Cloud / Server 7.8+
Python 2.7 or 3.7+
Sphinx 1.8 or 4.1+
The community and development for this extension can all be found at this project's GitHub repository:
Atlassian Confluence Builder for Sphinx - GitHub
https://github.com/sphinx-contrib/confluencebuilder
Your First Extension
In this topic, we'll teach you the fundamental concepts for building extensions. Make sure you have Node.js and Git installed, then install Yeoman and VS Code Extension Generator with:
Once you have learned the basics of Visual Studio Code Extension API in the Hello World sample, it's time to build some real-world extensions. While the Extension Capabilities section offers high-level overviews of what an extension can do, this section contains a list of detailed code guides and samples that explains how to use a specific VS Code API.
In each guide or sample, you can expect to find:
- Thoroughly commented source code.
- A gif or image showing the usage of the sample extension.
- Instructions for running the sample extension.
- Listing of VS Code API being used.
- Listing of Contribution Points being used.
- Real-world extensions resembling the sample.
- Explanation of API concepts.
Visual Studio Code is built with extensibility in mind. From the UI to the editing experience, almost every part of VS Code can be customized and enhanced through the Extension API. In fact, many core features of VS Code are built as extensions and use the same Extension API.
This documentation describes:
- How to build, run, debug, test, and publish an extension
- How to take advantage of VS Code's rich Extension API
- Where to find guides and code samples to help get you started
- Following our UX guidelines for best practices
Code samples are available at Microsoft/vscode-extension-samples.
Async Language Server Protocol plugin for vim8 and neovim.
The core specifications for XMPP are developed at the Internet Engineering Task Force (IETF) - see RFC 6120, RFC 7590, RFC 6121, and RFC 7622 (along with a WebSocket binding defined in RFC 7395).
The XMPP Standards Foundation develops extensions to XMPP in its XEP series. This page lists Draft and Final XEPs as well as experimental proposals that are currently under consideration.
Good places for developers to start are the compliance suites, as well as the technology overview pages.
Password store template for teams
This repository contains a base template for a password store repository to be used by teams.
It contains:
A README.md to adapt to your team
A script to setup a unique alias based on the directory name.
A Makefile with some common toolsThis is a perl extension for rxvt-unicode that allows changing the font size on the fly with keyboard shortcuts. It has the following features:
Supports both xft and X11 fonts; X11 fonts work in both full form and as aliases.
Supports all four font settings: font, boldFont, italicFont and boldItalicFont and changes them in accordance with the base font (the first one from font).
Can apply the font change globally for the whole server, so that new terminals will inherit the same size, and even save it to ~/.Xresources to be able to survive a reboot.
Should work even with complicated font setups like the example in the urxvt man-page.
sieve - Thunderbird Sieve Addon