Remotely was created by Translucency Software with the goal of making IT support tools that adhere to the following ideals:
- IT shops should be able to decide if they want to host their own servers.
- A remote console can be used to solve many problems without ever needing to inconvenience the user with full desktop control.
- Remote support tools should allow technicians to accomplish tasks without an excessive amount of clicking and waiting for pages to load.
I am running some legacy OSes (Windows 10, …) inside libvirt/KVM virtual machines and since I got my new 4K displays (hello Home Office), I was annoyed that I could not full-screen them on the large displays.
So finally I took some time to investigate and quickly (to my surprise) found the solution. As if we were back in the 1990ties, I did not provide the virtual machine with enough video RAM to properly go to the higher resolutions.
Your design as a Powerful Prototype
Does your project need PCBs, parts, or stencils? AISLER has you covered. Everything you need to get your electronics project built. Manufactured within six business days and shipped to you for free world-wide. Boost your productivity without blowing your budget.
This Ansible playbook is meant to help you run your own Matrix homeserver, along with the various services related to that.
That is, it lets you join the Matrix network using your own @<username>:<your-domain> identifier, all hosted on your own server (see prerequisites).
We run all services in Docker containers (see the container images we use), which lets us have a predictable and up-to-date setup, across multiple supported distros (see prerequisites) and architectures (x86/amd64 being recommended).
Installation (upgrades) and some maintenance tasks are automated using Ansible (see our Ansible guide).

orchestrator is a MySQL high availability and replication management tool, runs as a service and provides command line access, HTTP API and Web interface. orchestrator supports:
Mitogen is a Python library for writing distributed self-replicating programs.
There is no requirement for installing packages, copying files around, writing shell snippets, upfront configuration, or providing any secondary link to a remote machine aside from an SSH connection. Due to its origins for use in managing potentially damaged infrastructure, the remote machine need not even have free disk space or a writeable filesystem.
It is not intended as a generic RPC framework; the goal is to provide a robust and efficient low-level API on which tools like Salt, Ansible, or Fabric can be built, and while the API is quite friendly and comparable to Fabric, ultimately it is not intended for direct use by consumer software.
The focus is to centralize and perfect the intricate dance required to run Python code safely and efficiently on a remote machine, while avoiding temporary files or large chunks of error-prone shell scripts, and supporting common privilege escalation techniques like sudo, potentially in combination with exotic connection methods such as WMI, telnet, or console-over-IPMI.
What you see above is a tool to reorder the pages of a PDF file, into the order as described by Brent Yorgey here (called “Möbius double-sided printing” here). Basically, it reorders the n pages [1, 2, …, n] of a PDF file into the order [1, m+1, 2, m+2, 3, m+3, … m, 2m], where m = ⌈n/2⌉, and the final page 2m is omitted if it doesn't exist (i.e., if n is odd).
To use this tool, just upload a PDF file above, then click on the link to download a new PDF file with reordered pages.
Welcome to the bpython documentation files. This is where you can find all about using and customizing the bpython interpreter.
If you want to find out more about the bpython interpreter you can visit our website: http://bpython-interpreter.org
bpython is a fancy interface to the Python interpreter for Linux, BSD, OS X and Windows (with some work). bpython is released under the MIT License. It has the following (special) features:
- In-line syntax highlighting
- Readline-like autocomplete with suggestions displayed as you type.
- Expected parameter list for any Python function.
- "Rewind" function to pop the last line of code from memory and re-evaluate.
- Send the code you've entered off to a pastebin.
- Save the code you've entered to a file.
- Auto-indentation.
- Python 3 support.
Drahtseil & Zubehör
Gurtband & Zubehör
Karabinerhaken
Schlüsselringe & Zubehör
Verbindungselemente
Ketten & Zubehör
Schmiernippel
Sonstiges
Werbemittel
In 2010, it was an easy decision to use a commercial DNSSEC signer to deploy DNSSEC on APNIC’s reverse zones. Because much of the signer’s management was automated, we only had to worry about updating the parent delegation signer (DS) record separately.
So, even though we had to consider the scheduled Key Signing Key (KSK) rollover, updating the parent DS record on time was never an issue, since it would not roll-off the old key unless the new DS record had been updated in the parent zone.
In 2019, RFC 8624 (Algorithm Implementation Requirements and Usage Guidance for DNSSEC) was released. The minimum recommended DNSKEY algorithm changed to RSASHA256, and there was a strong recommendation to use ECDSAP256SHA256 as it provides more cryptographic strength with a shorter signature length than either RSASHA256 or RSASHA512.
RSASHA1 was APNIC’s DNSKEY algorithm for almost 10 years, so the need to upgrade was it was inevitable. When it was time to upgrade, algorithm rollover was supported and well documented.
Following the recommendations in RFC 8624, we decided to migrate APNIC’s existing DNSKEY algorithm from RSASHA1 to ECDSAP256SHA256. The whole process took about a week to complete, without breaking the DNSSEC chain of trust.
Once we’d migrated, it was great to see the new (short) signatures from our zones.
What else could we ask for?
When you insert data into a database and run COMMIT you expect things to be there: Atomically, Consistent, Isolated and Durable, like Codd commanded us 40 years ago, but also quickly. There is a surprising amount of sophistication being poured into this, but since I do not want to shame MongoDB and Redis developers in this post, I am not going to talk about that much in this place.
We are instead trying to understand what our databases are doing all day, from the point of view of the storage stack.
Kam immer wieder von Neuem an die Spitze: Der Musiker und Produzent Nile Rodgers. Nach Erfolgen mit seiner Band CHIC produzierte er Songs für Diana Ross, Michael Jackson, Madonna oder Daft Punk und Eric Clapton. ARTE widmet ihm ein Porträt und im Anschluss ein Konzert mit seinen besten Hits.
Der Musikproduzent Nile Rodgers wurde 1952 in einem armen Stadtteil von New York geboren. Seine Karriere begann in der Band der "Sesamstraße", später spielte er für die Hausband des legendären Apollo Theater in Harlem. Eine herausragende Begabung, aber auch harte Arbeit, Menschlichkeit und Fairness verhalfen ihm zu seinem großen Erfolg im Musikgeschäft.Musiker wie Madonna, David Bowie, Diana Ross, Michael Jackson, David Guetta, Daft Punk und viele andere vertrauten dem "Hitmaker", der ihrer Karriere entscheidende Impulse gab. Der Schlüssel zu seinem Erfolg ist wohl, dass Nile Rodgers es perfekt versteht, sich an den persönlichen Musikstil jedes Künstlers anzupassen. Die Dokumentation betrachtet Nile Rodgers‘ unkonventionelles Schaffen und wirft mit Hilfe von Archivbildern, Clips, Anekdoten und exklusiven Beiträgen von Zeitgenossen einen Blick hinter die Kulissen seiner Tätigkeit als erfolgreicher Produzent der Superstars.
Dokumentation von Marjory Déjardin (F 2015, 52 Min)
Da gerade die ersten EU-Zulassungen für Impfstoffe gegen Sars-CoV2 bevorstehen, haben Viele Fragen zur Sicherheit einer derart schnell entwickelten Impfung. In diesem Zusammenhang fällt zurzeit sehr häufig das Beispiel von den Narkolepsiefällen nach der Impfung gegen die Schweinegrippe 2009/2010. Das nehme ich zum Anlass, nach meinem Artikel von vor zwei Jahren den aktuellen Stand der Forschung zu diesem Thema etwas ausführlicher zusammenzufassen.
Click is a Python package for creating beautiful command line interfaces in a composable way with as little code as necessary. It's the "Command Line Interface Creation Kit". It's highly configurable but comes with sensible defaults out of the box.
It aims to make the process of writing command line tools quick and fun while also preventing any frustration caused by the inability to implement an intended CLI API.
Click in three points:
- Arbitrary nesting of commands
- Automatic help page generation
- Supports lazy loading of subcommands at runtime
Isn't it awesome how optparse and argparse generate help messages based on your code?!
Hell no! You know what's awesome? It's when the option parser is generated based on the beautiful help message that you write yourself! This way you don't need to write this stupid repeatable parser-code, and instead can write only the help message--the way you want it.
The core specifications for XMPP are developed at the Internet Engineering Task Force (IETF) - see RFC 6120, RFC 7590, RFC 6121, and RFC 7622 (along with a WebSocket binding defined in RFC 7395).
The XMPP Standards Foundation develops extensions to XMPP in its XEP series. This page lists Draft and Final XEPs as well as experimental proposals that are currently under consideration.
Good places for developers to start are the compliance suites, as well as the technology overview pages.